产品中心

[求助] DZ关于1064错误和hostinger主机商的错误解决

关于Discuz!无法安装的问题,我们进行了测试,发现是数据库的问题:Hostinger给我们使用的是最新5.5版本的MySQL,而Discuz!使用的是老版本的MySQL,由于新版的MySQL中使用ENGINE并放弃了TYPE函数  放弃了TYPE函数,因此您需要按照以下步骤来安装Discuz!

1、 将程序解压并上传至服务器;

2、 用文本编辑器或其他编辑软件打开/install/data/install.sql文件;

3、 将其中所有的TYPE=替换为ENGINE=;(要改动的文件三个左右,不知道的朋友一般会失败!)

4、 在浏览器运行安装文件。

这样您就能顺利安装Discuz!了,如果还有问题,请通过工单告知我们的工作人员。感谢您使用Hostinger,祝您使用愉快!
还不行的话,我们提供给你改动好的hostinger新数据库版的版本(只有UTF8没有GBK大家就委屈一下用吧!

附加就是改好的哦UTF8!(文件过大,百度云盘吧!),不会下载的加我QQ:357459415我给你发过去!
本帖由百度经验和DZ论坛Rover封米原创!转载的话请留下地址!做人要素质!
管理大大,记得加哟!这样会有更多的人在Hostinger上使用DZ的!
链接: https://pan.baidu.com/s/1qXStfA0 密码: v4ey

云南五星装饰 滇IPC:0350317427310